Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000025 [SkyOS 5.0 - Beta] Applications minor always 2004-05-23 21:05 2004-10-06 14:58
Reporter Kelly View Status public  
Assigned To Kelly
Priority normal Resolution fixed  
Status resolved  
Summary 0000025: Quake I and Quake II will not run.
Description When trying to run Quake I, I click it in the start menu, the mouse turns to the "thinking" mouse for only a fraction of a second, and that's it. No window ever pops up. No notification window either.

For Quake II, I start it from the start menu. The loading window comes up and sits there for about 4-7 seconds. Then it disappears and the notification window comes up. I click for more information and get:

"Applications:
/boot/programs/quake2/quake.app caused an unhandled exception 0E at 0x06DADF64. The application will be terminated.

Additional error information:
EIP: 20015CB6 CS: 0023 DS: 002B ES: 002B
ESP: 077DFC00 SS: 0018

Read the debug log file for a more detailed exception report."
Additional Information
Tags No tags attached.
Environment
Reported for build
Fixed in build
VersionType
Attached Files

- Relationships

-  Notes
(0000021)
robert (administrator)
2004-05-23 21:09

Quake I is fixed.

Kelly, can you capture debug infos in vmware?
(0000025)
Kelly (administrator)
2004-05-23 21:24

In VMWare, Quake II runs fine. It gets through the window part, and then everything is good. I played through a short game. :)

On my real install (1GHz PIII, TNT2), it opens the loading window, and then crashes with the above info. I unfortunately cannot do a serial debug capture with this computer, so the above is the only information I have.
(0000028)
robert (administrator)
2004-05-24 06:40

How much RAM do you have?
(0000029)
Kelly (administrator)
2004-05-24 07:18

I believe that it has 192MB of SDRAM. Should be plenty, I would think.
(0000031)
jkindley (reporter)
2004-05-24 19:30

Quake II on my home computer crashes because the ISS isn't initialized (No sound drivers for my Dell Latitude I guess)

Quake II at work on VM Ware 4.5.1 , crashes. I only have 96M ram setup for this vertual system so maybe the problem is that ??
(0000032)
robert (administrator)
2004-05-24 21:51

Thanks for the tip with the ISS. That may be the problem.

And yes, 96MB is too less, because Quake II alone needs ~80MB of RAM.
(0000034)
sbreen (reporter)
2004-05-25 03:45

I have 512mb with ISS working (sb audigy) on a real install and Quake II crashes like Kelly reported. (GeForce 3 ti 200 videocard)
(0000035)
Kelly (administrator)
2004-05-25 03:50

So the question is: Why does it seem to work fine on VMWare, but not a hardware install?
(0000115)
Kelly (administrator)
2004-07-26 13:08

I'm going to resolve this, because it appears in the unofficial 7.5 build the developers received, this has been resolved. I played through the first level of Quake II last night. :)
(0000116)
Kelly (administrator)
2004-07-26 13:12

Like I posted, seems this is fixed now. If it happens to someone else, please let me know and I will re-open it.

- Issue History
Date Modified Username Field Change
2004-05-23 21:05 Kelly New Issue
2004-05-23 21:09 robert Note Added: 0000021
2004-05-23 21:09 robert Status new => feedback
2004-05-23 21:24 Kelly Note Added: 0000025
2004-05-24 06:40 robert Note Added: 0000028
2004-05-24 06:40 robert Severity feature => minor
2004-05-24 07:18 Kelly Note Added: 0000029
2004-05-24 19:30 jkindley Note Added: 0000031
2004-05-24 21:51 robert Note Added: 0000032
2004-05-25 03:45 sbreen Note Added: 0000034
2004-05-25 03:50 Kelly Note Added: 0000035
2004-06-28 15:09 robert Project @1@ => @2@
2004-07-26 13:08 Kelly Note Added: 0000115
2004-07-26 13:12 Kelly Status feedback => resolved
2004-07-26 13:12 Kelly Resolution open => fixed
2004-07-26 13:12 Kelly Assigned To => Kelly
2004-07-26 13:12 Kelly Note Added: 0000116
2004-10-06 14:58 robert Project @2@ => SkyOS 5.0 - Beta


Mantis 1.1.4[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker