Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000306 [SkyOS 5.0 - Beta] Applications minor always 2004-09-22 05:22 2004-11-24 10:47
Reporter Nemo View Status public  
Assigned To robert
Priority normal Resolution fixed  
Status resolved  
Summary 0000306: DevStudio flaws
Description DevStudio fails to save file for a new "example code" project (GUI).
Additional Information I went to New Project and gave it a name.
- For some reason the place it chooses to put it is /home/projectname/ instead of /home/username/projectname/, which is pretty annoying.
  REPRODUCEABLE

- But anyway, when trying to Compile File, it says "Autosaving ..." then "Unable to save current file." then goes on trying to compile the file it couldn't save.
  UNABLE TO REPRODUCE

- Also at the very end of the example C/C++ GUI program there seems to be the character 'P' immediatly after the '}'
  REPRODUCEABLE

Using the version is beta 7.9
Tags No tags attached.
Environment
Reported for build
Fixed in build
VersionType
Attached Files

- Relationships

-  Notes
(0000172)
Nemo (reporter)
2004-09-22 05:27

That's /boot/home/... on both those paths, of course :)
(0000173)
Nemo (reporter)
2004-09-22 05:30

I discovered that the problem is that I initially created the project with upper-case name "SkIRC", however for whatever reason it later tries to save the file as "skirc.c" and has an error. When passed to gcc it also says it cannot find the file, since "skirc.c" doesn't exist, but "SkIRC.c" does.
(0000185)
Nemo (reporter)
2004-09-26 20:00

The second problem in Addtl Info above can be reproduced by using capital letters in the name of the project's files.
(0000186)
Nemo (reporter)
2004-09-26 20:19

I am using SkyFS btw, which seems to be case-sensitive, unlike FAT.

- Issue History
Date Modified Username Field Change
2004-09-22 05:22 Nemo New Issue
2004-09-22 05:27 Nemo Note Added: 0000172
2004-09-22 05:30 Nemo Note Added: 0000173
2004-09-26 19:30 robert Additional Information Updated
2004-09-26 20:00 Nemo Note Added: 0000185
2004-09-26 20:19 Nemo Note Added: 0000186
2004-10-06 14:58 robert Project @2@ => SkyOS 5.0 - Beta
2004-11-24 10:47 robert Status new => resolved
2004-11-24 10:47 robert Resolution open => fixed
2004-11-24 10:47 robert Assigned To => robert


Mantis 1.1.4[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker