Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000310 [SkyOS 5.0 - Beta] Drivers major always 2004-09-24 23:36 2005-11-08 13:12
Reporter Thom Holwerda View Status public  
Assigned To robert
Priority normal Resolution fixed  
Status resolved  
Summary 0000310: Network connection fails (beta 7.9)
Description My network connection *always* gets lost while using networking on 7.9.

I'm using a RTL-8139 card, and also saw that this "bug" (if it was the same) is supposed to be fixed already. Guess this one is new.
Additional Information
Tags No tags attached.
Environment
Reported for build
Fixed in build
VersionType
Attached Files

- Relationships

-  Notes
(0000177)
Nemo (reporter)
2004-09-25 17:33

When filing bug reports like this you should be more detailed. You should provide information about the entire environment you are working in (VMware? native? if VMware, using bridged networking? NAT? what? If native, what hardware (just the NIC may not be enough), such as chipset?).
It would be extremely beneficial to Robert if you could also provide him with debug output from SkyOS when this occurs.
It is also essential to state WHEN the problem occurs, not just "while using networking on 7.9". Does it happen when you start SkyOS? Does it happen when you try to use networking? Does it happen at random times?

All of these will significantly speed up the process of fixing this bug.
(0000180)
Thom Holwerda (reporter)
2004-09-25 17:48

Okay, I'll do :)

I run native. My networking setup is pretty basic: I have cable internet, with the following setup:

router+switch (one of them two-in-ones)-->another switch-->skyos pc, using a realtek-8139 NIC. The firewall inside the router is turned OFF.

As said, this simply always happens, I'm never able to maintain my network connection. Sometimes I have connection for half an hour after reboot, sometimes for only 2 minutes. It's completely random.

Now, I'll try to get a serialcable on monday, and then connect my laptop to it.

Sorry, I'm linda new to buf reporting, I'll be more specific from now on.
(0000201)
centimetre (developer)
2004-10-04 15:37

Thom please could you confirm if this is still an issue in Beta 8, if so please provide details of your network card etc.
(0000206)
hollovoid7 (reporter)
2004-10-04 23:29

Im having the same issue in beta 8.1, network works for few mins sometimes then stops, n every time I check the settings dhcp is always turned back off. with a VIA rhineII network card
(0000215)
Thom Holwerda (reporter)
2004-10-05 15:08

The connection seems way more stable than in the 7.9 beta (currently using 8.1). Even after a reboot connection is still up. I think this bug can be closed-- but you probably need others to confirm too.
(0000216)
hollovoid7 (reporter)
2004-10-05 15:51

I am running in Native, cable internet, Router with firewall turned off (such as Thom) under 8.1 using VIA RHINE II integrated Network, and I still get disconnects very quickly, only temp solution is to re - enable dhcp every couple mins (since it seems to disable itself quite often) or to enter the info manually, but that only lasts so long, since my cable providor leases ip addresses and expires them after a certain amount of time.

- Issue History
Date Modified Username Field Change
2004-09-24 23:36 Thom Holwerda New Issue
2004-09-25 17:33 Nemo Note Added: 0000177
2004-09-25 17:48 Thom Holwerda Note Added: 0000180
2004-10-04 15:37 centimetre Note Added: 0000201
2004-10-04 15:37 centimetre Status new => feedback
2004-10-04 23:29 hollovoid7 Note Added: 0000206
2004-10-05 15:08 Thom Holwerda Note Added: 0000215
2004-10-05 15:51 hollovoid7 Note Added: 0000216
2004-10-06 14:58 robert Project @2@ => SkyOS 5.0 - Beta
2005-11-08 13:12 robert Status feedback => resolved
2005-11-08 13:12 robert Resolution open => fixed
2005-11-08 13:12 robert Assigned To => robert


Mantis 1.1.4[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker