Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000662 [SkyOS 5.0 - Beta] minor always 2005-02-02 14:56 2005-03-29 18:24
Reporter adamk View Status public  
Assigned To robert
Priority normal Resolution fixed  
Status resolved  
Summary 0000662: DNS resolution is failing.
Description
I have SkyOS running in vmware on my workstation... vmware is running a bridged network, and I've acquired an IP address in SkyOS: 10.1.3.83. SkyOS shows my gateway as 10.1.3.1 (correct) and my DNS as 10.1.1.2 (also correct).

I can ping 10.1.1.2. However, any attempts to ping www.osnews.com fails. You can see the debug output below:

2753853: 42/ping.app: start dns
ksock.c: (fcntl) Blocking 0
echo 3

I can, however, ping 67.18.254.190, the IP address for osnews.com

Additional Information
Tags No tags attached.
Environment
Reported for build
Fixed in build
VersionType
Attached Files

- Relationships

-  Notes
(0000457)
robert (administrator)
2005-02-02 20:42

Do you have any chance to do network sniffing when SkyOS tries to lookup the DNS? SkyOS has a network monitor, but it is not working correctly yet. Maybe you could use a tool like EtherReal or Etherpeak. (They are able to capture network packets sent from vmware too.). This will help me a lot.
(0000458)
adamk (reporter)
2005-02-02 20:54

This is from tcpdump on the linux host machine. I grabbed all the output (which was a lot) and grepped for 10-1-3-83, the IP of the virtual machine. You can see the queries for resolution of www.osnews.com... So apparently SkyOS is querying... Odd.
(0000459)
adamk (reporter)
2005-02-02 20:55

D'oh...

http://68.44.156.246/network-traffic.txt [^] :-)
(0000460)
robert (administrator)
2005-02-02 21:15

Hmm, this is strange. Do you have a possibility to check the DNS log file from the DNS Server?
This is really strange.
(0000461)
adamk (reporter)
2005-02-02 22:38

Not sure... I'll have to take a look tomorrow.
(0000463)
robert (administrator)
2005-02-03 08:50

When using linux, do you get multiple DNS server IPs from the DHCP? Maybe a primary and a secondary.
(0000466)
adamk (reporter)
2005-02-03 12:39
edited on: 2005-02-03 12:40

No, we currently only have one internal DNS server at work (though that will be changing on Friday, probably).

edited on: 02-03-05 12:40
(0000470)
robert (administrator)
2005-02-09 19:43

Adam, do you think it is possible that you tcpdump the SkyOS->DHCP server communication when trying to get an IP address?
Maybe the final "yes, I will use your offer" doesn't get sent from SkyOS, so that the DHCP/DNS gets not activated for the SkyOS IP/MAC address.
(0000471)
adamk (reporter)
2005-02-09 20:00

Robert, I can do some more testing, but it probably won't be till next week. Sick with the flu at the moment, and I'm gonna have a load of work to get through when I get back in the office :-)
(0000472)
robert (administrator)
2005-02-11 08:40

Ok, no problem.

I debugged the DHCP code once more and this can't be the problem. If you get a chance, maybe you could send me a tcpdump log of a DNS query from SkyOS and maybe from a Linux machine. (a full dump, including the raw packet datas).

Maybe I can find a difference between this two packets.
Thanks a lot!
(0000483)
robert (administrator)
2005-02-14 07:38

Which network card are you using with SkyOS?
(0000484)
adamk (reporter)
2005-02-14 12:47

Well, the vmware machine is using an AMD PCNet card.
(0000485)
robert (administrator)
2005-02-14 14:40

I need your to know the type of your physical card, even if you are using vmware, because there was an error with padding on the ethernet level, which may affect the physical card too.
(0000486)
robert (administrator)
2005-02-14 14:41

Oh, one more thing. In the tcpdump, is the destination MAC address where SkyOS tries to send the DNS packet to, the MAC address of the DNS server? Maybe SkyOS is not correctly routing and sends the packet to your router. (Although the IP address may be the one of your DNS server)
(0000487)
adamk (reporter)
2005-02-14 15:01

The physical card is an Intel EtherexpressPro (eepro100, under linux).

I'm gonna have to play with tcpdump some more since it's not actually showing me the MAC address for the DNS server (or any other machine).
(0000488)
robert (administrator)
2005-02-14 15:47

Ok, great.
In the meantime you can try to manually set your network mask to 255.255.0.0 (if it is set to 255.255.255.0).
(0000489)
adamk (reporter)
2005-02-14 16:28

Changing the netmask didn't have any affect.

Think it matters that the nameserver is on a different subnet then my machine?

Adam
(0000586)
robert (administrator)
2005-03-28 22:37

Does this error still occure with beta8.4?
(0000591)
adamk (reporter)
2005-03-29 15:02

Nope, it's working fine now in beta8.4

- Issue History
Date Modified Username Field Change
2005-02-02 14:56 adamk New Issue
2005-02-02 20:42 robert Note Added: 0000457
2005-02-02 20:54 adamk Note Added: 0000458
2005-02-02 20:55 adamk Note Added: 0000459
2005-02-02 21:15 robert Note Added: 0000460
2005-02-02 22:38 adamk Note Added: 0000461
2005-02-03 08:50 robert Note Added: 0000463
2005-02-03 12:39 adamk Note Added: 0000466
2005-02-03 12:39 adamk Note Added: 0000467
2005-02-03 12:39 adamk Note Deleted: 0000467
2005-02-03 12:40 adamk Note Edited: 0000466
2005-02-09 19:43 robert Note Added: 0000470
2005-02-09 20:00 adamk Note Added: 0000471
2005-02-11 08:40 robert Note Added: 0000472
2005-02-14 07:38 robert Note Added: 0000483
2005-02-14 12:47 adamk Note Added: 0000484
2005-02-14 14:40 robert Note Added: 0000485
2005-02-14 14:41 robert Note Added: 0000486
2005-02-14 15:01 adamk Note Added: 0000487
2005-02-14 15:47 robert Note Added: 0000488
2005-02-14 16:28 adamk Note Added: 0000489
2005-03-28 22:37 robert Note Added: 0000586
2005-03-29 15:02 adamk Note Added: 0000591
2005-03-29 18:24 robert Status new => resolved
2005-03-29 18:24 robert Resolution open => fixed
2005-03-29 18:24 robert Assigned To => robert


Mantis 1.1.4[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker