Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000830 [SkyOS 5.0 - Beta] major always 2005-03-30 03:09 2006-03-28 11:13
Reporter adamk View Status public  
Assigned To robert
Priority normal Resolution fixed  
Status resolved  
Summary 0000830: eepro100 driver crash.
Description
When activating the eepro100 NIC in my computer, I get a total system lockup:

http://68.44.156.246/skyos-eepro.txt.gz [^]
Additional Information
Tags No tags attached.
Environment
Reported for build
Fixed in build
VersionType
Attached Files

- Relationships

-  Notes
(0000600)
digitaldisaster (reporter)
2005-03-31 01:59

Moving the /boot/system/drivers/eepro100.dld file and manually loading the driver with "mod -l eepro100.dld" gives "Unable to load kernel module eepro100.dld (FFFFFFFF)" and a system notification for "Binary Image Error"
(0000611)
robert (administrator)
2005-04-01 09:02

Looks like that the IO/Ports the EEPRP100 driver tries to register are in use already.
By detecting this, the eepro100 driver failes to load, but gets not unloaded completely.
Right after the eepro100 driver was loaded, the setup application loads the ELO Touchscreen driver. This modules resist in the same kernel memory space as the already "half unloaded" eepro100 driver. So, when you are finally activating the eepro100 driver, the kernel jumps right into the ELO module. (Will fix this)

Do you mind checking the device manager and look for a device which requested the I/O Ports 0xB000 - 0xB040 ?
This would help me a lot.
(0000612)
robert (administrator)
2005-04-01 10:23

Nevermind, should be fixed.

- Issue History
Date Modified Username Field Change
2005-03-30 03:09 adamk New Issue
2005-03-31 01:59 digitaldisaster Note Added: 0000600
2005-04-01 09:02 robert Note Added: 0000611
2005-04-01 09:02 robert Status new => feedback
2005-04-01 10:23 robert Status feedback => resolved
2005-04-01 10:23 robert Resolution open => fixed
2005-04-01 10:23 robert Assigned To => robert
2005-04-01 10:23 robert Note Added: 0000612
2005-05-20 09:29 robert Project SkyOS 5.0 - Beta => @5@
2006-03-28 11:13 robert Project @5@ => SkyOS 5.0 - Beta


Mantis 1.1.4[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker