Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000855 [SkyOS 5.0 - Beta] major always 2005-04-01 05:26 2005-11-08 15:30
Reporter Kelly View Status public  
Assigned To robert
Priority high Resolution fixed  
Status resolved  
Summary 0000855: Networking dies in beta 8.4.
Description Networking (Internet connectivity, anyway) seems to die after either X amount of time, or X amount of data, has passed. It seems that if Firefox is trying to connect to a site, and is stalled, if you open terminal and try to ping something, it wakes it back up and lets it finish the page it was trying to load. I will include my debug capture below.
Additional Information 45: 1232656: 45/screensaver.app: Check: 1489285994 123265600310242440243
77
9
1: recv: 57316 594594nection now
90:
1: New
45: 1233666: 45/screensaver.app: Check: 1489285994 1233666042app: Check: 1455598924 1163321320205041: recv: 30652
45: 9
5
1: recv: 26228 64r.app: Check: 1
4
1: New offset: 26296104valid line.
45: N
45: 1234676: 45/screensaver.app: Check: 1489285994 1234676133704p: Check:
45: New offset: 5805221704 64irefox-bin.ap
45: r
45: 1235686: 45/screensaver.app: Check: 1489285994 1235686203 102
1: New
1
45: recv: 58424 594: 9
5
5
51:
1: recv
45: New
48: open.c: Redirect to socket close5: recv: 59024 594 -2 106
1: recv: 2
45: 1236696: 45/screensaver.app: Check: 1489285994 123669626994nsaver.app: Check:
45: New offset: 602241: New offset: 280
45: 1237706: 45/screensaver.app: Check: 1489285994 123770633224ew offset: 2867
1: Ne
18: tcp.c: Warning! Doing not nice cl
45: 1238716: 45/screensaver.app: Check: 1489285994 1238716403rect to socket close7
1: recv: 28676 64
    
52: C
45: 1259927: 45/screensaver.app: Check: 1489285994 12599277808: recv: 5624 594/firefox-bin.app:
98: New offset: 6224: Rem
45: 1260937: 45/screensaver.app: Check: 1489285994 1260937871ffset: 6824:

1: recv: 32720 64
98: recv: 6824 594: New offse
45: 1261947: 45/screensaver.app: Check: 1489285994 12619479274 70: 1237706076 9507
98: New offset: 7500120: 51/firefox-bin
45: 1262958: 45/screensaver.app: Check: 1489285994 1262958004: 1237706076 95
98: recv: 7576 70: 89275
   
     
98: New of
98: recv: 9672 7060 644
51: recv:
98: New offset:
45: 1274068: 45/screensaver.app: Check: 1489285994 12740687238: New offset: 9824: 355288 -2 1280 102
98: recv: 9824 705528
45: 1275078: 45/screensaver.app: Check: 1489285994 1275078805v: 9900 70: 36
45: 1043773:
98: New offset: 9976Check: 130107
45: 1276088: 45/screensaver.app: Check: 1489285994 127608884652706076 95781
45: 1044
98: recv: 10052 594app: Check: 130107
45: 1277098: 45/screensaver.app: Check: 1489285994 12770989360ffset: 362641
45:
98: New offset: 10728r.app: Check: 130107
45: 1278109: 45/screensaver.app: Check: 1489285994 1278108981 05 -2 145 -2
1: r
98: recv: 10804 70 924666: 51
1: New
98:
45: 1279119: 45/screensaver.app: Check: 1489285994 1279119076nnec
1: New o
98: New offset: 10956899025: 51
1: recv: 2
98:
101: mount.c: Syncing filesystem skyfs (/boot)ffset: 145808 1280 102424pp: in
1
98: recv: 14
101: skyfs.c: Syncing disk... New offset: 15180nsaver.app:
101: buffer.c: Still dirty blocks: -167v: 3820
98: New offset: 15256n
1: New o
101: syshandl.c: Shuting down tasks....app: Che
98: New offset: 15332690New
101: kill.c: Sending terminate to all processes...
98: New offset: 15408/screensaver.app: Che
98: re
101: sched.c: Interrupt task from sleepingfset: 15768set: 395360 10245 128
18: tcp.c
101: sched.c: Interrupt task from sleeping04 10659954356: 924837: 51/fir
18: tcp.c:
41: signalc.: Task iss.app gets killed by signal 15eensaver.app: Check
52: open.c: Redirect to socket
46: signalc.: Task iss.app_ISSChecker gets killed by signal 15P connection...er.app: Check: 1301074804 1068014957
52: Connec
43: signalc.: Task sysserv.app gets killed by signal 15069025: 45/screensaver.app: Check: 1301074804 10690250

51: signalc.: Task firefox-bin.app gets killed by sig
                   
                       
1: rec
49: signal.c: Warning! Returning to user mode after handling signal without rest081145832bin.app: invalid l
1: New
51: 1164336: 51/firefox-bin.app: Not a gener
art!untc
54: signalc.: Task firefox-bin.app_moz-thread_moz-thread gets killed by signal 1pp: Size: 8 88 1280 102
45: 1083166: 45/screensaver
51: 1164346: 51/firefox-bin.
5p
50: signal.c: Warning! Returning to user mode after handling signal without rest4352: 51/firefox-bin.app: Size: 8 1084176029: 891230: 51/fir
51
least25:
51: 11
art!: 51
41: Kill thread iss.app_ISSChecker / 46. Check: 1301074804 1085186098 64app: inv
51: 116
41: Moving to reaper task...
                              
51: Kill thread firefox-bin.app_moz-thread / 55.fset: 1674425751: 51/firef
1
1:
98: recv: 16744 70 494
51: Moving to reaper task...ng not nice close!
98: recv: 16820
51: kill.c: Unable to send KILL signal to thread 55l
1: New
1: N
98: recv: 17048 7041024 1280
1: rec


51: Kill thread firefox-bin.app_moz-thread / 56.4 237: 51/fi
1: recv: 53
98: New offset: 17368 23
1: New
51: Moving to reaper task...app: Check:
98: New offset: 17436
1
51: kill.c: Unable to send KILL signal to thread 56740
98: New offset: 17504ct to socket close553
98:
51: Kill thread firefox-bin.app_moz-thread_moz-thread / 57.t: 5594
98: recv: 17580 7012
1: r
52: Connec
98: New offset: 17656n
51: Moving to reaper task...70
1: recv: 56540 59
98: New offset:
51: kill.c: Unable to send KILL signal to thread 57t: 0140 5946
98: New offset: 17808ew offset:
45: 1
51: Kill thread firefox40 594
                    
51: kill.c: Unable to send KILL signal to thread 6588irect to socket close
98: recv: 20088 70a generic
51: Kill thread firefox-bin.app_moz-thread_moz-thread / 66. 701/firefox-bin.app:
98: New offset: 20240: 926047: 51/firefox

98
51: Moving to reaper task...: New offset: 20316091: 899588: 51/f
51: kill.c: Unable to send KILL signal to thread 66fset: 20392screensaver.app: Chec
98: recv: 20392 70
51: Kill thread firefox-bin.app_moz-thread_moz-thread / 67.en.c: Redirect to socket close: Check: 1301074804 1117508244firefo

51: Moving to reaper task...1/firefox-bin.app
45: 1118518: 45
99
51: kill.c: Unable to send KILL signal to thread 679 529 90 1280 10
1: recv: 20468 70
51: 965562: 51/f
51: Kill thread firefox-bin.app_moz-th
51: Moving to reaper task...30639: 45/s
45: 1172981: 45/screensa
51: kill.c: Unable to send KILL signal to thread 7440 102402480 102
45: 968989:
45: 1131649: 45/s
45:
51: Kill thread firefox-bin.app_moz-thread / 75. 1280 10248 1280 10245 86 1
1: recv: 2596 6
45: 1132659:
51: Moving to reaper task...4 1
1: New offset: 20948g! Doing not
51: kill.c: Unable to send KILL signal to thread 751303556 1175002119 Check: 1301074804 1133669316offs
51: Kill thread firefox-bin.app_moz-thread_moz-thread / 76. 1471303556 1176012210 Check: 1301074804 113467938326576: 51/fire
1
51: Moving to reaper task...
1: recv
45: 1
1: New offset: 21016r
51: kill.c: Unable to send KILL signal to thread 76 Check: 1471303556 1177022nvalid line.
       
51
51: Moving to reaper task... line. -1 21
100: New offset: 24048
51: kill.c: Unable to send KILL signal to thread 93.app: inv
100: New offset: 24124ox-bin.app: invalid
51: Kill thread firefox-bin.app_moz-thread / 94.t: 2420019006: 51/firefox-bin.
100: recv: 24200 705/scre
51: Moving to reaper task...nsaver.app: Check: 14
100: recv: 242
51: kill.c: Unable to send KILL signal to thread 94nvalid line
4
45:
100: recv: 24352 70aver.app: Chec
51: Kill thread firefox-bin.app_moz-thread_moz-thread / 99.refox-bin.a
45: r
1: New offset: 24504ensaver.app: Check:
1: recv:
51: Moving to reaper task...set: 24580 line
  
1: New offs
     
48: open.c: Redirect to socket close
3: New offset: 26792
2: sched.c: (2
48: udpsock.c: Destroy udp socket 0 139721

98: New offset: 27392: rec
48: udpsock.c: Udp socket destroyed_t97 gets killed by signal 9offset:
48: open.c: Redirect to socket close 27992 594
97: 97 / vci.app_t97: aut
48: udpsock.c: Destroy udp socket 0e and no want exit06irefox-bin.app:
48: udpsock.c: Udp socket destroyed5942 166 -2
98: recv: 2890
codeoffs
2: sched.c: (2 / TaskReaper) got signal, abort.refox-bi
98: recv: 28980 210 -1 21 1249 21 1280
29: giwm.c: Destroy desktop done.signal, abort.recv: 29196 2107

5
36: dep.c: Remove DataExchangePort sys_DebugRequest, task: debug.appse of no want exit code 1280
98: New offset: 29724lose TCP connectio
2: sched.c: (2 / TaskReaper) got signal, abort.got signal, abort.nnection
1: recv:
98: recv:
2: sched.c: (2 / TaskReaper) got signal, abort.pp: Check: 1484033646 11841: recv: 30156 594 Ne
29: listener.c: Remove client due task delete. -1 943 9 943 1280 1024inv
51: recv: 15376 5
29: listener.c: Remove client due task deleteck
51: 1185941: 51/firefox-bin.app: invalid l
29: listener.c: Remove client due task deletea
1: New offset: 32860iting for 56331313 a
1:
48: open.c: Redirect to socket close: invalid line. -1 922 9 922 1280 10
48: udpsock.c: Destroy udp socket 0invalid line. -1 21 1148 21 1280 10
48: udpsock.c: Udp socket destroyedvalid line. -1 109 68 109 1280 1024
48: open.c: Redirect to socket closevalid line. -1 0 -1 21 1280 10245
51
48: udpsock.c: Destroy udp socket 0id line. -1 771 68 771 1280 1024ecv
48: udpsock.c: Udp socket destroyed offset: 3406042
52: open.c: Re
51:
32: <core: kernel> 0x0010B568invalid line. -1 778 68 778 1
32: <core: kernel> 0x0012065C660 215024ffset: 2
51: 92
1:
32: <core: kernel> 0x00120A9D2: 51/firefox-bin.app: invali
32: <core: kernel> 0x00106F40d line. 911 -2 911 17
99: udp
29: listener.c: Remove client due task dele
32: <core: kernel> 0x0018F265: 45
51: 1186093: 51/firefox-
32: <core: kernel> 0x0018098186 943 1280 1024 1024
18: tcp
32: <core: kernel> 0x00183F7912068 5941/fi
1: New offset
5
2: sched.c: (2 / TaskReaper) got signal, abort. 942 85 942 1280 1024 offset: 369169999777, Wai
2: sched.c: (2 / TaskReaper) got signal, abort. 1186132: 51/firefox-bin.app: invalid line. -1
32: <core: kernel> 0x00182C15: New offset: 38116ck: 123770
32: <core: kernel> 0x0010B568e
51: 1186164: 51/firefox-bin
32: <core: kernel> 0x0012065C09 1280 1024app: Check: 12377
32: <core: kernel> 0x00120A9D 641485: 51/
 

51:
1
      
32: <core: kernel>
98: recv: 41336 708402 1280 1024lose
98: N
45: 1192253: 45/screensaver.app: Ch
34: <core: kernel> 0x00106F40e.
45:
98: New offset: 4148
51: open.c: Redirect to socket close263: 45/screensaver.app: Check: 1489
51: Connect: Close TCP connection...v: 41556 64app: Check: 123770
98: Ne
51: Connect: Close TCP connection now. State was: 19408018/527346045: 99
98: New offset: 41700pp: Check: 1237706076
98:
51: Remove timer for 19408018. Timeout: 0heck: 1489285994 1195283509996280:
98: r
51: open.c: Redirect to socket closeew offset:
45: 1196293: 45/screensav
51: Connect: Close TCP connection...1
98: New offset: 42224k: 1
1: New o
51: Connect: Close TCP connection now. State was: 193F0018/5ck: 1489285994 1197303636ai
98: recv: 42300 70t leas (112080
49: open.c: Redirect to socket close3: 45/screensaver.app: Check: 148928
49: Connect: Close TCP connection...eck: 1237706076 9
98: recv: 42452 70

101: kill.c: Sending terminate to desktop...9285994 1207404310w offset: 211321
98: New o
101: kill.c: All tasks terminated9
45: 1208414: 45/screensaver.app
101: kill.c: Sending kill to all processes...
98: recv: 44420 70ffset: 218001/fire
98: New
101: kill.c: All tasks killed.p: Check: 1489285994 120942443
101: gidraw.c: Message to invalid windowect to sock
5
98: rec
1: recv: 25940 64p
101: <core: kernel> 0x00190448 26008y udp socket 024
98:
1:
101: <core: kernel> 0x001904AF
1: New offset: 26084destroyed
101: <core: kernel> 0x0018F265eensaver.app: Check: 148928599
101: <core: kernel> 0x00186A0298: recv: 44800 70e. 454 -4
5

101: <core: kernel> 0x0010BB0Freensaver.app: Check: 14892859
101: <core: kernel> 0x00101BE3ew offset: 44952ecv: 21996 191
101: <core: kernel> 0x00109BC5
101: unmoung:e close
45: 1
101: devfs.c: unmount.app: Check: 14892859
101: usage is 0o socket closee
101: listener.c: listen device not foundon
1: recv: 26084 64nnection...1280
t
1:
101: unmoung:6152 9
1: rec
101: listener.c: listen device not foundtate
1: New offset: 2622824
18: tcp.c:
101: unmoung:6494: 45/scre
101: listener.c: listen device not found18. Timeout: 00: 45/screensaver.app: Che
101: unmoung:
1: re
52: o
101: listener.c: listen device not found02851/fi
5
93: ope
1: r
1:
52: Connect:
101: unmoung: /dev/hd0aw offset: 481047 12
101: -------------------------------------------------------------
101: Device Dirty NonDirty L
ocked
101: /dev/hd0a 0 4096 0
101: buffer.c: Cache statistic:
101: -------------------------------------------------------------
101: Device Dirty NonDirty L
ocked
101: /dev/hd0a 0 0 0
101: skyfs: unmount done.
101: listener.c: listen device not found
101: regser.c: Bootdevice not mounted.
101: Serialization aborted
101: buffer.c: Still dirty blocks: -198
101: syshandl.c: Rebooting...
101: reboot.c: Event: 01000000
101: reboot.c: Shutdown...
101: vm86.c: 16bit opcode (ea)not handled
101: vm86.c: 16bit opcode (ea)not handled
101: vm86.c: 16bit opcode (ea)not handled
101: vm86.c: 16bit opcode (ea)not handled
101: vm86.c: 16bit opcode (ea)not handled
101: vm86.c: 16bit opcode (ea)not handled
Tags No tags attached.
Environment
Reported for build
Fixed in build
VersionType
Attached Files txt file icon debug_samba_issue.txt [^] (260,933 bytes) 2005-09-24 00:35
zip file icon Debug.zip [^] (124,715 bytes) 2005-10-06 20:07

- Relationships

-  Notes
(0000610)
Kelly (administrator)
2005-04-01 05:27

This is an earlier capture, that I grabbed before shutting down. Looks like it includes some additional information at the top.

51: New
51: 1162861: 51/firefox-bin.app: invalid line. -1 0 -1 21 1280 10240: 51/firefox-bin.app: invalid line. -1 21 1148 21 1280 102451/fir

1: recv: 49380 59441: 923666: 51/fir
1: New offset: 499804line
51: 1006218: 5
1: recv: 49980 594invalid line. -1 0
1: New offset: 50580irefox-bin.app: i
1:
1: recv: 50580 594refox-bin.app: inv
1: New offset: 51180/firefox-bin.app: Fo
1: recv: 51180 5940856
51: 894421:
1: New offset: 51780
5
5
51:
51: 100624
1: recv: 51780 64app: nsFontMetric
1: New offset: 51848back font2 1280 1024
1: recv: 51848 5949: 51/firefox-bin.
1: New offset: 524482 64/f
51: 1006255:
1: recv: 52448 594 Size: 8-2 1280 10
1: New offset: 53048screensav
45: 100640
1: recv: 53048 594pp: Check: 130107
1: New offset: 53648
51: 1163103: 51/firefox-bin.app: invalid line. -1 0 -1 21 1280 10240018. Timeout: 0 8360 70 86696
1: recv: 25880 594923762:
52: open.
1: recv: 54316 594et close 89 819 90
1: New offset: 54916creen
52: Connect: C
1: recv: 54916 594...1: Redirect to
1: New offset: 55516
52: Connect: Close
1: recv: 55516 594 State was: 179700
1: New offset: 56116616481664 recv: 9
51
1: recv: 56116 5943: 5
52: Remove ti
1: New offset: 56716
45: New offset: 5805221704 64irefox-bin.ap
45: recv: 58052 3662177219 90 1280 1
1
45: New offset: 5842464 1280 102
1: New
1
45: recv: 58424 594: 9
5
5
51:
1: recv
45: New offset: 59024nsaver.app: Check: 13
45: recv: 59024 594 -2 106
1: recv: 27
45: New offset: 59624ot
1: New offset:
4
45: recv: 59624 594nsaver.app: Check:
45: New offset: 602241: New offset: 280768
45: recv: 60224 5941: recv: 28076 594p
45: New offset: 60824ew offset: 2867
1: Ne
18: tcp.c: Warning! Doing not nice close!p.c: Sequence number to small. Got: 18342
52: open.c: Redirect to socket close7
1: recv: 28676 64
1: New offset: 650241554280 102424o
52:
1: recv: 65024 594connection now. St
1: New offset: 8811: 45/screensave
1: recv: 88 64301074804 1017
1: New offset: 156 Remove timer for
1: recv: 156 594: 0 invalid l
45
1: New offset: 756nsaver.app: Check:
1: recv: 756 59421676p: inv
1: N
1: New offset: 13561280 1024 1280 1
1:
1: recv: 1356 59419531: 45/screens
1: New offset: 19561074804 10195317401
1: recv: 1956 5944nvalid line. 399
1: New offset: 255676-2
45: 1020541:
1: recv: 2556 64p: Check: 130107
1: New offset: 2624t: 30712: 51/firefo
1: recv: 2624 594 30712 279 -2 401
1: New offset: 3224creensaver.app: Che
51: recv: 3224 594551874996 21524: 5
51: New offset: 3824offset: 31216app: in
51: recv: 3824 5942: 45/screensaver.
51: New offset: 44244 10225620532 now. S
51: recv: 4424 594cv: 31452 64924069
51: New offset: 50241023573: 45/screensa
51: recv: 5024 5941074804 1023573144
51: New offset: 5624128 594
92: New offs
45: 1026602: 45/screensaver.a
51: 1163783: 51/firefox-bin.app: invalid line. -1 21 1148 21 1280 1024en.c: Redirect to sock
45: 1027612: 45/screensaver.app: Check: 1301074
51: 1163790: 51/firefox-bin.app: invalid line. -1 0 -1 21 1280 10242
52: C
45: 1028622: 45/screensaver.app: Check: 1301074804 10286223
98: recv: 5624 594/firefox-bin.app:
98: New offset: 6224: Rem
45: 1029632: 4
98: recv: 6224 594Check: 1301074804
98: New offset: 6824:

1: recv: 32720 64
98: recv: 6824 594: New offse
45: 10
98: New offset: 7424.app: Check: 1301074
98: recv: 7424 70: 1237706076 9507
98: New offset: 7500120: 51/firefox-bin

97: recv: 7500 70reensaver.app: Ch
97: New offset: 757652543: 1237706076 95
98: recv: 7576 70: 89275
   
     
98: New offset: 7652
98: recv: 8100 64fset: 3472424280
98: New offset: 8168eensaver.app: Check:
98: recv: 8168 3668796 953777305iref
98: New offset: 8540ine. 739 89 738 90 1
98: recv: 8540 70 45/screensaver.a
98: New offset: 8616 1037712944478735551
98: recv: 8616 70irefox-bin.app: i
98: New offset: 8692 1038723: 45/screens
98: recv: 8692 70301074804 1038723
98: New offset: 8768 901059:
45: 924375:
98: recv: 8768 70p: Ch
45: 1039733
98: New offset: 8844 Check: 1301074804 1
98: recv: 8844 7066 -2 1280 10
51:
98: New offset: 8920in.app: inv
1:
     
98: recv: 8920 70
98: New offset: 97481042763: 45/screensa
98: recv: 9748 7001074804 10427632
98: New offset: 9824: 355288 -2 1280 102
98: recv: 9824 705528
1: recv: 224
98: New offset: 9900e
1: New offset: 225
98: recv: 9900 70: 36
45: 1043773:
98: New offset: 9976Check: 1301074804 10
98: recv: 9976 70957817: 45/screen
98: New offset: 10052706076 95781
45: 1044
98: recv: 10052 594app: Check: 1301074
98: New offset: 10652cv: 36196 64t: Close
98: recv: 10652 70ffset: 362641
45:
98: New offset: 10728r.app: Check: 1301074
98: recv: 10728 70-1 21 1148 21 1280
98: New offset: 10804t: 05 -2 145 -2
1: r
98: recv: 10804 70 924666: 51
1: New
98: New offset: 10880app: invalid
1: recv:
98: recv: 10880 702: Connec
1: New o
98: New offset: 10956899025: 51
1: recv: 2
98: recv: 10956 594
            

1: New
98: recv: 11784 705/screensaver.app:
98: New offset: 118608823683all. Got: 1789
98: recv: 11860 70 1789064067 atid l
98: New offset: 11936: 45/screensaver.app:
98: recv: 11936 70104983481082
leas
98: New offset: 12012screensaver.app: Chec
98: recv: 12012 70843: 45/screensave
98: New offset: 1208804 1050843819d line.
98: recv: 12088 70rect to socket clo
98: New offset: 12164051854: 45/screensave
98: recv: 12164 7074804 1051854918-b
98: New offset: 12240484 -2 48
52: Connect
98: recv: 12240 70: 1052863: 45/scre
98: New offset: 1231601074804 105286396947
98: recv: 12316 70app: inval
52: Rem
98: New offset: 12392
45: 1053875: 45/scre
98: recv: 12392 70 1301074804 105387
98: New offset: 12468cket clos
98: recv: 1
98: New offset: 133721024 1280 1
1: recv:
98: recv: 13372 594/screensaver.app: C
98: New offset: 13972142851/
18: tcp.c: Se
98: recv: 13972 70all. Got: 17890635
98: New offset: 1404845/screensaver.app: C
98: recv: 14048 70589243692:
51: 924
98: New offset: 14124p: inv
leastine.
3:
98: recv: 14124 704: 45/screensaver.
98: New offset: 14200 1059934420id
18: tcp
98: recv: 14200 70not nice close!n.a
98: New offset: 142760944: 45/screensaver.
98: recv: 14276 70804 1060944486x-bi
98: New offset: 14352 921446:

52: Connect
98: recv: 14352 701061954: 45/screen
98: New offset: 14428074804 1061954557lose
98: recv: 14428 70. State was: 10C68
98: New offset: 14504: recv: 23288 594
98: recv: 15332 70
1: recv: 39400 64
98: New offset: 15408/screensaver.app: Che
98: recv: 15408 3538477139468 64n.app:
98: New offset: 15768set: 395360 10245 128
18: tcp.c: Warning! Doing not nice close!k: 1301074804 10659954356: 924837: 51/fir
18: tcp.c: Warning! Doing not nice close! s
45: 1067004: 45/screensaver.app: Check
52: open.c: Redirect to socket closep.c: Wait until all packets are sent
52: Connect: Close TCP connection...er.app: Check: 1301074804 1068014957
52: Connect: Close TCP connection now. State was: 17998018/1
45: 1069025: 45/screensaver.app: Check: 1301074804 10690250
52: Remove timer for 17998018. Timeout: 0: 40736
                   
51: recv: 15920 70072055: 45/screens
51: New offset: 1599674804 1072055226p: in
52: Connect: Close TCP connection...all packets are sen
45: 1073065: 45/
52: Connect: Close TCP connection now. State was: 10A78018/1 Wait until all packets are sent. (10C68018)2
45: 1074075: 4
52: Remove timer for 10A78018. Timeout: 07535867: 45/screensaver.app: Check: 12377
99: 1164256: 99/firefox-bin.app_moz-thread_moz-thread: start dns 1301074804 107508542636 594086:
51: 925263: 5
1: New offset: 41
99: ksock.c: (fcntl) Blocking 0 45/screensaver.app: Check: 130
51: 1164296: 51/firefox-bin.app: Font: Arial is: 0385: 45/screensav
52: tcp.c
45: 1077105: 45/screens
51: 1164301: 51/firefox-bin.app: nsFontMetricSkyOS.cpp: Using fallback: 51
52: tcp.c: Wait until a
                                       
51: 1164441: 51/firefox-bin.app: Not a generic fount086196162280 102424pp:
51:
51: recv: 43280 54520x-b
51: 1164447: 51/firefox-bin.app: Size: 8saver.app: Check: 1301074804 1087206232
51: 1164456: 51/firefox-bin.app: Font: Arial is: 0w offset
45: 1088216: 45/screensaver.app: Check: 13
51: 1164461: 51/firefox-bin.app: nsFontMetricSkyOS.cpp: Using fallback font2 59
45: 1089226: 45/screensaver.app: Check: 1301074804 1089226381: recv: 4
51: 1164469: 51/firefox-bin.app: Size: 8 4687202402
45: 1090236: 45/screensaver.
45: 1164681: 45/screensaver.app: Check: 1455598924 1164681448
18: recv: 46940 5949 85 1280 10
45: 1091246: 45/screensaver.
98: recv: 15996 70804 10912464987540
98: New offset: 16072r
18: New offset: 481
98: recv: 16072 701092256: 45/screen
98: New offset: 16148074804 1092256564t: 4
98: recv: 16148 70: 9257
1: recv: 48
98: New offset: 162245: 1093266: 45/screen
98: recv: 16224 70301074804 10932666
98: New offset: 16300:
1: New offset: 4994
98: recv: 16300 70
                
98: New offs
1
98: New offset: 16820oing not nice close!
98: recv: 16820 221 51/firef
3:

1: re
98: New offset: 17048pp: inval
1: New
1: N
98: recv: 17048 7041024 1280
1: rec

98: New offset: 17124saver.app: Check: 130
98: recv: 17124 237: 51/fi
1: recv: 53
98: New offset: 17368 23
1: New offset:
45
98: recv: 17368 64nsaver.app: Check:
98: New offset: 17436
1: New offset: 5474
98: recv: 17436 64va
51: recv: 54740
98: New offset: 17504ct to socket close553
98: recv: 17504 70072
1: recv:
52:
98: New offset: 17580nnection...fset: 5594
98: recv: 17580 7012
1: r
52: Connec
98: New offset: 17656n now. State was: 124
98: recv: 17656 70
1: recv: 56540 59
98: New offset: 17732 New off
52: Remove t
98: recv: 17732 70Timeout: 0140 5946
98: New offset: 17808ew offset:
45: 10973
98: recv: 17808 70app: C57740 594
98: New offset: 18872nsaver.app: Check: 13
98: recv: 18872 70280 1024
1: New of
98: New offset: 1894832 to
45: 964948: 45/
98: recv: 18948 70reensaver.app: Che
98: New offset: 19024442 502 -2 749 -2 128
98: recv: 19024 702 59
51: recv: 796
98: New offset: 19100/screensaver.app: Che
98: recv: 19100 70397563ecv: 1396 59
98: New offset: 19176: New offset: 1996280
98: recv: 19176 70 45/screensaver.ap
98: New offset: 19252107407589t: 2528ox-bi
98: recv: 19252 70 tcp.c: Warning! D
98: New offset: 1932817: 45/screensaver.ap
98: recv: 19328 704 110841764151/fir
98: New offset: 19404neric fountlid line.
98: recv: 19404 7009427: 45/screensa
98: New offset: 194804804 1109427709Size:
98: recv: 19480 706010: 51/firefox-b
98: New offset: 19556 1110437: 45/screensa
98: recv: 19556 701074804 1110437773
98: New offset: 19632o socket close1: 9260
98: recv: 19632 7045: 1111447: 45/sc
98: New offset: 197081301074804 1111447837
98: recv: 19708 70 in
52: Connect: C
98: New offset: 19784w.
                  
98: recv: 1
98: New offset: 20012991e
51: 965189: 51/f
98: recv: 20012 70e: 83516: 51/firef
98: New offset: 20088irect to socket close
98: recv: 20088 70a generic fountli

98: New offset: 20164saver.app: Check: 130
98: recv: 20164 701/firefox-bin.app:
98: New offset: 20240: 926047: 51/firefox

98: recv: 20240 70eensaver.app: Chec
98: New offset: 20316091: 899588: 51/firef
98: recv: 20316 70 line. 145
51: 965
98: New offset: 20392screensaver.app: Chec
98: recv: 20392 70981764-2
51: 9655
98: New offset: 20468: Not a generic fount
99: open.c: Redirect to socket close: Check: 1301074804 1117508244firefo
99: udpsock.c: Destroy udp socket 0 51/firefox-bin.app
45: 1118518: 45
99: udpsock.c: Udp socket destroyed1118518309 is: 00 89 529 90 1280 10
1: recv: 20468 70
51: 965562: 51/f
1: New offset: 20544eensaver.app: Check:
45: 1166921: 45/screensaver.app: Check: 1455598924 1166921594123568: 45/screensaver.app: Check: 1301074804 1123568646ack f
45: 1167931: 45/screensaver.app: Check: 1455598924 1167931665124578: 45/screensaver.app: Check: 1301074804 1124578714606:
45: 1168941: 45/screensaver.app: Check: 1468920432 1168941719125588: 45/screensaver.app: Check: 1301074804 1125588786app:
45: 1169951: 45/screensaver.app: Check: 1469929421 1169951807126598: 45/screensaver.app: Check: 1301074804 1126598846 1280
45: 1170961: 45/screensaver.app: Check: 1470903799 1170961853127610: 45/screensaver.app: Check: 1301074804 1127610003 21 1
100: 1171266: 100/ping.app: start dns
 
              
                  
51: 863669: 51/fir
45: 967
45: 1130639: 45/s
45: 1172981: 45/screensaver.app: Check: 1471303556 117298196926405673223550740 102402480 102
45: 968989:
45: 1131649: 45/s
45: 1173992: 45/screensaver.app: Check: 1471303556 1173992079 1280 10248 1280 10245 86 1
1: recv: 2596 6
45: 1132659: 45/s
1: recv: 20872 70eck: 1301074804 1
1: New offset: 20948g! Doing not nice cl
45: 1175002: 45/screensaver.app: Check: 1471303556 1175002119 Check: 1301074804 1133669316offset: 3164n.app: invalid line.
45: 1176012: 45/screensaver.app: Check: 1471303556 1176012210 Check: 1301074804 113467938326576: 51/fire
1: New offset: 33
1: recv: 20948 643 9
1: recv
45: 1
1: New offset: 21016r.app: Check: 130107
45: 1177022: 45/screensaver.app: Check: 1471303556 1177022nvalid line.
                                       
45:
100: New offset: 22072r.app: Check: 13010748
100: recv: 22072 21026770: 51/firefox-bi
100: New offset: 222889 -1 499 -
45: 1141749
100: recv: 22288 210 Check: 1301074804 1
100: New offset: 22504fire
51: 926777: 51/fi
100: recv: 22504 306784:
45: 1142759: 45
100: New offset: 22816: 1301074804 114275991
100: recv: 22816 21011165: 51/fi
5
51: 9
100: New offset: 230325: 1143770: 45/screens
100: recv: 23032 210074804 1143770046fir
100: New offset: 23248eric
51
51: recv: 3436
100: recv: 23248 70
100: New offset: 240485/screensaver.app: Che
100: recv: 24048 7010255x-bin.app: inv
100: New offset: 24124ox-bin.app: invalid li
100: recv: 24124 70creensaver.app: Che
100: New offset: 2420019006: 51/firefox-bin.
100: recv: 24200 705/screensaver.app:
100: New offset: 24276ensaver.app: Check: 14
100: recv: 24276 70: 900027: 5
5
51: 9
100: New offset: 24352pp: invalid line
4
45:
100: recv: 24352 70aver.app: Check: 14
100: New offset: 24428pp: invali
45: New off
1: recv: 24428 70refox-bin.a
45: r
1: New offset: 24504ensaver.app: Check:
1: recv: 24504 70537901868: 51
1:
1: New offset: 24580 line
  
1: New offs
5
51:
100: New offset: 2488454950: 45/screensaver.
100: recv: 24884 7030 11549507491280 1
100: New offset: 24960 10241: 770330:
5
51:
100: recv: 24960 7072: 98/ping.app: st
100: New offset: 25036 1280 10242 1
18: t
98
1: recv: 25036 70 Blocking 0ose!51
1: New offset: 251121: 9
1: recv: 24780
1: recv: 25112 70 li
1: New offset
1: New offset: 25188280 10
1: recv: 2538
1: recv: 25188 70: 51/
1: New offs
1: New offset: 25264/firefox
45: 1155961
45: 1180102: 45/screensaver.app: Check: 1471303556 1180102541417 1280 1024irefox-bin.app: inval
4
51: 970348:
           
100: recv: 25264 70
3: recv: 26576 2107896set: 13372-bin
3: New offset: 26792
2: sched.c: (2 / TaskReaper) got signal, abort.et: 139721

98: New offset: 27392: recv: 13
1:
97: signalc.: Task vci.app_t97 gets killed by signal 9offset: 27992invalid line. -1 21 1
98: recv: 27992 594
97: 97 / vci.app_t97: auto reap myself because of thread state and no want exit06irefox-bin.app: inv
98: New offset: 289041280 1024 5942 166 -2
98: recv: 2890
codeoffs
2: sched.c: (2 / TaskReaper) got signal, abort.refox-bi
98: recv: 28980 210 -1 21 1249 21 1280
2: sched.c: (2 / TaskReaper) got signal, abort.recv: 29196 2107

51: 8724
51: 975
98: New offs
95: 95 / vci.app: auto reap myself because of no want exit code 1280
98: New offset: 29724lose TCP connection..
51: 1185975: 51/firefox-bin.app: invalid line. -1 109 68 109 1280 1024
51: 1185990: 51/firefox-bin.app: invalid line. -1 771 68 771 1280 1024
51: 1185997: 51/firefox-bin.app: invalid line. -1 778 68 778 1280 1024
51: 1186062: 51/firefox-bin.app: invalid line. -73 52 82 52 1280 1024
51: 1186069: 51/firefox-bin.app: invalid line. -72 51 81 51 1280 1024
51: 1186077: 51/firefox-bin.app: invalid line. -73 29 82 29 1280 1024
51: 1186084: 51/firefox-bin.app: invalid line. -72 30 81 30 1280 1024
51: 1186093: 51/firefox-bin.app: invalid line. -1 943 86 943 1280 1024
51: 1186100: 51/firefox-bin.app: invalid line. -1 942 85 942 1280 1024
51: 1186132: 51/firefox-bin.app: invalid line. -1 922 85 922 1280 1024
51: 1186164: 51/firefox-bin.app: invalid line. -1 109 0 109 1280 1024
51: 1186172: 51/firefox-bin.app: invalid line. -1 771 0 771 1280 1024
51: 1186179: 51/firefox-bin.app: invalid line. -1 778 0 778 1280 1024
45: 1186186: 45/screensaver.app: Check: 1486123348 1186186911
45: 1187203: 45/screensaver.app: Check: 1487191122 1187203005
51: 1187717: 51/firefox-bin.app: Exit nsAppShell...
45: 1188213: 45/screensaver.app: Check: 1488208587 1188213079
45: 1189223: 45/screensaver.app: Check: 1489186063 1189223125
45: 1190233: 45/screensaver.app: Check: 1489285994 1190233213
45: 1191243: 45/screensaver.app: Check: 1489285994 1191243235
45: 1192253: 45/screensaver.app: Check: 1489285994 1192253326
45: 1193263: 45/screensaver.app: Check: 1489285994 1193263373
45: 1194273: 45/screensaver.app: Check: 1489285994 1194273460
(0000613)
Another One (reporter)
2005-04-01 10:54

Unfortunately Kelly is damn right, gonna test it once more today, but I'm afraid this is a real problem.
(0000617)
Kelly (administrator)
2005-04-03 21:09

I re-did the bug capture, saving it to a file (rather than copying it from the Hyperterminal window). Hopefully this is sufficient. Be careful, it's a 3.5MB download.

http://www.skyos.org/bug_captures/skyos_network_firefox_b84.TXT [^]
(0000924)
Coldfirex (reporter)
2005-09-20 02:48

I see this alot with Firefox in Beta 8.5. Strange thing is, that I do not see it with Bash if I use FTP.
(0000927)
Darknesss (reporter)
2005-09-20 08:39

I had similar issues with lots of traffic through samba. restaring the service was a sollution. Will check if I have a debuglog
(0000930)
Darknesss (reporter)
2005-09-24 00:37

I was copying files to skyos using samba when the \\skyos computer (vmware though) was suddenly not available any more... (pre-alpha 8.6)

I attached the debuglog above (debug_samba_issue.txt)
(0000931)
Darknesss (reporter)
2005-09-24 00:41

restarting the network (dhcp for new ip) seemed to fix this problem, but I restarted samba and stopped indexing as well (but those 2 alone were not enough)
(0000979)
adamk (reporter)
2005-10-05 13:31

I've seen something similar with samba. I tried to copy a 21 meg file over from a linux samba client to my skyos install (via vmware, but a similar thing happens natively with a realtek card). This is what I get:

[ adamk@memory - /mnt/home/adamk ]: cp ~adamk/sobek/Documents/serenity_m480.mov serenity_m480.mov.2
cp: writing `serenity_m480.mov.2': Input/output error

If I copy the file to the htdocs apache directory on the linux box and use wget from SkyOS, though, it works fine.
(0000982)
Coldfirex (reporter)
2005-10-06 20:10

Added another debug file. I booted up, went to an external ftp site, began d/l of a video. Eventually it stopped. I tried refreshing the page and going to a different site but it would not connect. I opened another tab in FF and that would not connect anywhere either. I was able to ping out just fine with Bash. Opening another instance of Firefox alongside the original worked correctly to access the Internet. After this, the original FF instance still would not connect anywhere.
Hope this helps some.

- Issue History
Date Modified Username Field Change
2005-04-01 05:26 Kelly New Issue
2005-04-01 05:27 Kelly Note Added: 0000610
2005-04-01 10:54 Another One Note Added: 0000613
2005-04-03 21:09 Kelly Note Added: 0000617
2005-09-20 02:48 Coldfirex Note Added: 0000924
2005-09-20 08:39 Darknesss Note Added: 0000927
2005-09-24 00:35 Darknesss File Added: debug_samba_issue.txt
2005-09-24 00:37 Darknesss Note Added: 0000930
2005-09-24 00:41 Darknesss Note Added: 0000931
2005-10-05 13:31 adamk Note Added: 0000979
2005-10-06 20:07 Coldfirex File Added: Debug.zip
2005-10-06 20:10 Coldfirex Note Added: 0000982
2005-11-08 15:30 robert Status new => resolved
2005-11-08 15:30 robert Resolution open => fixed
2005-11-08 15:30 robert Assigned To => robert


Mantis 1.1.4[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker